Aiwyn Firm Portal Errors

Incident Report for Aiwyn

Resolved

Aiwyn's technical teams have deployed a fix and can confirm all functionality and features in the portals are fully restored. If any users report any issues moving forward, please contact support@aiwyn.ai so we can assist further.
Posted May 07, 2026 - 11:09 EDT

Update

The client portal is still operational, clients are able to access and sign engagement letters and process payments. Some functions like accessing and upload requests are not accessible.
Posted May 07, 2026 - 10:25 EDT

Identified

Aiwyn's technical teams have identified an issue with certain functions failing to load or erroring. This includes engagement letters, projects and contact records. Our teams are urgently working on a fix and we will notify you as soon as it's been released and all functionality is restored.

If you have any other questions in the interim please contact support@aiwyn.ai, thank you.
Posted May 07, 2026 - 10:14 EDT
This incident affected: Aiwyn Client Payment Portal and Aiwyn Firm Portal.